このページの翻訳:
ソースの表示
管理最近の変更サイトマップ

QX-S5524GT-4X2Qあれこれ

QX-S5524GT-4X2Qについて

QX-S5524GT-4X2QはNECの10G/40Gアップリンク対応のL3スイッチである。1000BASE-T 24ポート、10G SFP+ 4ポート、40G QSFPポート 2ポートのなかなか良さげな構成。

例によってH3CのOEMだが、H3C純正のラインナップにはピッタリ一致する製品は見当たらない。スペック的にはH3C S5560の下位版という感じ。HPのHPE FlexNetwork 5510 HIが一番近いように見える。

コマンド例集

コマンド体系はCiscoライクだけど、ちょいちょい違う。似すぎててCiscoに訴えられて変わったらしい。

基本

特権ビュー(特権モード)に入る。

<QX> system-view

適用中のコンフィグを表示

[QX] display current-configuration

保存済みのコンフィグを表示

[QX] display saved-configuration

設定の保存

[QX] save
The current configuration will be written to the device. Are you sure? [Y/N]:y
Please input the file name(*.cfg)[flash:/startup.cfg]
(To leave the existing filename unchanged, press the enter key):
flash:/startup.cfg exists, overwrite? [Y/N]:y
Validating file. Please wait...
Saved the current configuration to mainboard device successfully.

設定用IPアドレスの設定。VID=1のVLANインタフェースに対して設定する。

[QX] interface Vlan-interface 1
[QX-Vlan-interface1] ip address 192.168.0.254 24

ルーティング

デフォルトゲートウェイの設定

デフォルトゲートウェイは宛先0.0.0.0/0のスタティックルートとして設定する。パラメータは宛先アドレス/マスク長(アドレス表記も可)/ネクストホップ。

[QX] ip route-static 0.0.0.0 0 192.16.0.1

スタティックルートの削除

[QX] undo ip route-static ネットワークアドレス マスク ネクストホップ

全て削除する場合は

[QX] delete static-routes all

RIP

静的経路をRIPで再配布

[QX] rip 1
[QX-rip-1] import-route static

VLAN

VLANの概要表示

[QX] display vlan brief
Brief information about all VLANs:
Supported Minimum VLAN ID: 1
Supported Maximum VLAN ID: 4094
Default VLAN ID: 1
VLAN ID   Name                             Port
1         VLAN 0001                        FGE1/0/29  FGE1/0/30  GE1/0/13
                                           GE1/0/14  GE1/0/15  GE1/0/16
                                           GE1/0/17  GE1/0/18  GE1/0/19
                                           GE1/0/20  GE1/0/21  GE1/0/22
                                           GE1/0/23  GE1/0/24  XGE1/0/25
                                           XGE1/0/26  XGE1/0/27  XGE1/0/28
100       VLAN 0100                        GE1/0/1  GE1/0/2  GE1/0/3  GE1/0/4
                                           GE1/0/5  GE1/0/6  GE1/0/7  GE1/0/8
                                           GE1/0/9  GE1/0/10  GE1/0/11
                                           GE1/0/12

VLANの全情報を表示

[QX]display vlan all
 VLAN ID: 1
 VLAN type: Static
 Route interface: Configured
 IPv4 address: 192.168.0.254
 IPv4 subnet mask: 255.255.255.0
 Description: VLAN 0001
 Name: VLAN 0001
 Tagged ports:   None
 Untagged ports:
    FortyGigE1/0/29               FortyGigE1/0/30
    GigabitEthernet1/0/13         GigabitEthernet1/0/14
    GigabitEthernet1/0/15         GigabitEthernet1/0/16
    GigabitEthernet1/0/17         GigabitEthernet1/0/18
    GigabitEthernet1/0/19
    Ten-GigabitEthernet1/0/25
    Ten-GigabitEthernet1/0/26
    Ten-GigabitEthernet1/0/27
    Ten-GigabitEthernet1/0/28

 VLAN ID: 100
 VLAN type: Static
 Route interface: Configured
 Description: VLAN 0100
 Name: VLAN 0100
 Tagged ports:   None
 Untagged ports:
    GigabitEthernet1/0/1          GigabitEthernet1/0/2
    GigabitEthernet1/0/3          GigabitEthernet1/0/4
    GigabitEthernet1/0/5          GigabitEthernet1/0/6
    GigabitEthernet1/0/7          GigabitEthernet1/0/8
    GigabitEthernet1/0/9          GigabitEthernet1/0/10
    GigabitEthernet1/0/11         GigabitEthernet1/0/12

 VLAN ID: 200
 VLAN type: Static
 Route interface: Configured
 IPv4 address: 192.168.20.254
 IPv4 subnet mask: 255.255.255.0
 Description: VLAN 0200
 Name: VLAN 0200
 Tagged ports:   None
 Untagged ports:
    GigabitEthernet1/0/20         GigabitEthernet1/0/21
    GigabitEthernet1/0/22         GigabitEthernet1/0/23
    GigabitEthernet1/0/24

VLANの作成/VLANビューへの移動

[QX] vlan 100

VLANの削除

[QX] undo vlan 100

VLANのポートへの割り当て

VID=100のVLANを1GbEポート1~12に割り当てる

[QX] vlan 100
[QX-vlan100] port GE1/0/1 to GE1/0/12

VLANインタフェース(SVI)の作成

VLANインタフェースの作成と有効化。Ciscoでいう所のSVIの設定。

[QX] interface Vlan-interface 100
[QX-Vlan-interface100] ip address 192.168.10.254 24
[QX-Vlan-interface100] undo shutdown

ポート10をVLAN 100, 200のトランクポートにする。

[QX] interface GE1/0/10
[QX-GigabitEthernet1/0/10] port link-type trunk
[QX-GigabitEthernet1/0/10] port trunk permit vlan 100 200

サブネットベースVLAN

VLANに対応するネットワークアドレスを紐づける。

ip-subnet-vlanの第1パラメータはサブネットVLANの識別子で、付けても付けなくてもよい。

[QX] vlan 100
[QX-vlan320] ip-subnet-vlan 10 ip 192.168.10.0 255.255.255.0
[QX] vlan 200 
[QX-vlan470] ip-subnet-vlan 20 ip 192.168.20.0 255.255.255.0

ポート30をVLAN 100,200のタグなしメンバーとし、IPサブネットVLANを紐づける。なお、IPサブネットVLANを使うポートはハイブリッドポートの必要がある。

[QX] interface FGE 1/0/30
[QX-FortyGigE1/0/30] port link-type hybrid
[QX-FortyGigE1/0/30] port hybrid vlan 100 200 untagged
[QX-FortyGigE1/0/30] port hybrid ip-subnet-vlan vlan 100
[QX-FortyGigE1/0/30] port hybrid ip-subnet-vlan vlan 200

DHCP

DHCPリレー

[QX] dhcp enable
[QX] interface Vlan-interface 100
[QX-Vlan-interface100] dhcp select relay
[QX-Vlan-interface100] dhcp relay server-address 192.168.0.1

DNS

DNSプロクシ(DNSリレー)

[QX] dns proxy enable
[QX] dns server 192.168.0.1
network/qx-s5524gt-4x2q_tips.txt · 最終更新: 2020-11-11 03:47 by Decomo
CC Attribution-Noncommercial-Share Alike 4.0 International
www.chimeric.de Valid CSS Driven by DokuWiki do yourself a favour and use a real browser - get firefox!! Recent changes RSS feed Valid XHTML 1.0